We experience issues with payouts from 7/9

Minor incident Udbetalinger
2022-09-08 08:40 CET · 3 days, 23 hours, 52 minutes

Updates

Resolved

The error in the payouts from 7/9 is fixed

September 12, 2022 · 08:33 CET
Issue

We experience issues with payouts from 7/9. We will update a soon as we have fixed the issue!

September 8, 2022 · 08:43 CET

← Back