All transactions are currently failing

Major incident App
2022-07-27 11:28 CET · 41 minutes

Updates

Resolved

We are fully up again

July 27, 2022 · 12:09 CET
Monitoring

We are up again and are monitoring our system.

July 27, 2022 · 12:03 CET
Issue

We are currently experiencing problems with processing transactions. We are working on a fix and expect to be fully up very soon again

July 27, 2022 · 11:30 CET

← Back