We are experiencing problems with the transactions

Major incident App
2022-06-15 08:32 CET · 1 hour, 50 minutes

Updates

Resolved

The app is up and running again

June 15, 2022 · 10:22 CET
Issue

We are experiencing problems with the transactions and it is not possible to make transactions at the moment. We’ll update you soon.

June 15, 2022 · 08:33 CET

← Back