The pin function is not working at the moment

Major incident App
2022-05-25 09:24 CET · 16 minutes

Updates

Resolved

The problem is solved and the pin app is up and running again.

May 25, 2022 · 09:40 CET
Issue

It is not possible to make transactions with pin function, which is amounts over 350 kr

May 25, 2022 · 09:26 CET

← Back