We are experiencing problems with the transactions

Major incident App
2022-05-20 14:40 CET · 24 minutes

Updates

Resolved

The issues has been fixed and the Vibrant app is up and running again.

May 20, 2022 · 15:04 CET
Issue

We are investigating the issues with the transactions

May 20, 2022 · 14:40 CET

← Back