Transactions is showing an invalid status in dashboard

Minor incident Merchant Dashboard
2022-03-22 08:30 CET · 6 hours, 45 minutes

Updates

Resolved

Everything is working again

March 22, 2022 · 15:15 CET
Investigating

Currently an invalid status is show in the merchant dashboard. We are working on fixing the problem.

March 22, 2022 · 09:12 CET

← Back