We are currently experiencing minor payout delays

Minor incident Udbetalinger
2022-12-15 12:20 CET · 5 days, 3 hours, 41 minutes

Updates

Resolved

Everything is back to normal.

December 20, 2022 · 16:02 CET
Issue

We are currently experiencing minor payout delays on a small part of out payouts. We expect resolve this within the end of the week

December 15, 2022 · 13:15 CET

← Back