We have an issue with refunds/voids on all VISA cards currently

Minor incident App
2022-12-14 13:44 CET · 23 hours, 19 minutes

Updates

Resolved

The refund function for VISA cards is now working again

December 15, 2022 · 13:04 CET
Investigating

We have an issue with refunds/voids on all VISA cards currently. If refund is attempted with VISA card it will fail.

December 14, 2022 · 13:45 CET

← Back